[o2switch+WP] Supprimer le message « utf8mb4 nécessite une librairie client plus récente »

Depuis peu, certaines personnes ont vu apparaitre un message sur leur installation WordPress mentionnant que le jeu de caractères « utf8mb4 nécessite une librairie client plus récente ». Cela s’adresse à celles et ceux qui ont un hébergement chez o2switch. C’est mon cas : à priori, cela n’avait aucun impact négatif sur mes sites. Pour supprimer ce message, il y a une manipulation toute simple à effectuer.

Supprimer le message utf8mb4 nécessite une librairie client plus récente o2switch

Après plusieurs heures de recherche, c’est sur un groupe d’entraide Facebook que j’ai pu trouver la solution grâce à un certain Ludovic S. Clain. Visiblement suite à une mise à jour effectuée par les équipes de o2switch, une extension PHP a été activée par erreur. Il s’agit de l’extension mysqli. On peut la désactiver en se rendant dans cPanel puis PHP Selector.

Si après ça, votre site est en erreur veillez à réactiver l’extension nd_mysqli. En effet, celle-ci était activée chez moi sur mes précédentes versions de PHP (dont la 8.0). C’est ce qui m’a permis de résoudre le problème sans même devoir restaurer l’ensemble de mes bases de données.

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *